From: Ian Horrocks (email@example.com)
On April 15, tim finin writes: > "David R. Karger" wrote: > > None of the other names was any more natural to the man on the > > street. Since they are going to have to learn new vocabulary, we > > might as well use the previously defined terms. > > I hope the man in the street never sees any raw OWL or DAML anymore > than he should have to look at HTML or postscript. The person who > might have to look at the OWL description generated by an application, > tool or syntactically sugared surface language will be (IMHO) someone > like a software engineer, a system administrator or a DBA. They > probably won't be a person with an interest in KR, with advanced > degrees or who has ever worked in an R&D environment. > > I like Pat's notion of describing constraints on properties by > describing how they are used, but isn't this the domain of an > intuitive, high-level surface language (N3++?). We still need to > decide on what this compiles into and how to express it. That lower > level language needn't be optimized for human understandibility, > though it should not be obscure. DAML+OIL already includes this functionality - you can use maxCardinality, minCardinality and cardinality to restrict the way a property can be used w.r.t. a given class. In fact uniqueProperty and unambiguousProperty are just special cases where such a restriction is applied to the most general class (Thing). So, instead of declaring age (say) to be a uniqueProperty, you can simply state that a Thing has at most 1 age. Unfortunately, the means of stating such a thing in DAML+OIL is to assert that Thing is a subClass of a maxCardinality-1 restriction on age - which isn't much/any easier for our target audience to grok. Using a tool like OilEd, however, the check-box for uniqueProperty could be relabeled to say something like "A Thing can have at most one age" (where age is the property in question). As far as unambiguousProperty is concerned, this is just syntactic sugar and could be eliminated completely in favour of asserting that the inverse property is a uniqueProperty (which is what it means). Another idea would be to use this as a hint for a better/different key-word, i.e., uniqueInverseProperty. Actually, I have always thought that functionalProperty was a much better name, so we could also consider using functionalProperty and functionalInverseProperty. Regards, Ian > > The kind of people who may have to look at low level OWL are much more > likely to be familiar with descriptions from information systems > (e.g., one to many) than with the language of mathematical functions.
This archive was generated by hypermail 2.1.4 : 03/26/03 EST