From: David Martin (
Date: 04/11/02

tim finin wrote:

> Adam -- I had uniqueProperty and unambiguousProperty
> confused.  But, for the example you gave "Person has SSN"
> it should be both.  That is, hasSSN is both a uniqueProperty
> and an unambiguousProperty, since it is one-to-one (at least
> in the idealized world). I think this makes the example more
> interesting, in fact.
> The W3C Webont working group is looking for better names to
> use for these qualities of properties for its new language.
> What do people think of using names like oneToOneProperty,
> manyToOnePropoerty, oneToManyProperty, and manyToManyProperty.

UniqueProperty works well for me (I find it easy to grok), but I can't
say the same for UnambiguousProperty (I find it ambiguous :-).

I'm afraid oneToOneProperty, etc. will introduce more confusion than
they eliminate, because of the ambiguity around "one" - does it mean
"exactly one" or "at most one".  However, I supposed that could be
addressed by having names like oneToExactlyOneProperty and
OneToAtMostOneProperty, if those aren't seen as too cumbersome.

- Dave

> Tim

This archive was generated by hypermail 2.1.4 : 03/26/03 EST